OVERVIEW:

While using Jet Reports with Dynamics 365 Business Central Online, you may get the 500 Internal Server Error message. Below is a sample image of the message, where a user was navigating through the Jet Function Wizard to retrieve Business Central table in Jet Reports



ROOT CAUSE:

When a Business Central extension is uninstalled from the environment, the removal process does not clean up the extension's published Web Service objects. Jet Reports will always check the list of published Web Service objects and will generate the (500) Internal Server Error message if it finds orphaned objects.


SOLUTION: 

You will need to go the Web Services page in your Business Central environment and find these orphaned objects. In the example screenshot provided below, you can see residual objects are still listed in Web Service page after removing the QuickBooks extension. Removing them manually will immediately fix the issue with Jet Reports.




Another way to find orphaned objects is to look for ones without Object Name (i.e. Object Name column is blank). These orphaned objects are safe to delete.