OVERVIEW:

When you create Business Central Online (Public Cloud) data source in Jet Reports, you get the follow message upon logging to the Business Central environment.


ROOT CAUSE

This error occurs when the Business Central online tenant has unconventional name for its production environment. The default name of the production environment is Production. And Jet Reports is designed to access the tenant and find this environment during the login process. However, if you name your environment differently, such as Prod, it confuses the Jet Reports, hence the error message.


SOLUTION

You need to manually configure the Instance field of the Data Source (located in Web Service tab):

  1. Upon logging in and get the (400) Bad Request error, click OK
  2. The Data Source should now be populated with the environment information of the Business Central tenant.
  3. Go to Web Service tab of the Data Source's settings, and modify the Instance field as follow:
  • Change v1.0 part (in the beginning) to v2.0
  • Add /PROD (replace PROD with the custom name of your production environment) to the end of the link.